Problem with Thresholding

I am having a problem with the thresholding option.
I am trying to segment the CT spine - after loading the DICOM - The threshold option gives a range of -1024 to 1024 and it is impossible to change the range.
I was working fine in the last couple of days. I think the problem started after updating my mac to latest BigSur update release.
I am using the latest version of 3d slicer!

Is this the threshold range shown in Volumes module or in Segment Editor module?
Which Slicer version do you use?

Operating system:MacOSBigsur
Slicer version:4.13.0-2021-10-03 r30282 / 04d69cd
Expected behavior: The range of values for thresholding needs to show up to be able too threshold bone from CT spine
Actual behavior: I can’t change the thresholding bars. The values seen are from -1024 to -1024. It does not seem to read the range of values in the DICOMs. I have tried many files. Having the same problem.

Hello Andras,
It is showing in the Segment Editor module.
I am using the latest version 4.13.0 of October 4, 2021.
I noticed that this problem appeared after I updated my mac to the latest BigSur release. Before that, I did not have any problems. Also, I am having a problem re-analyzing the DICOMs I analyzed a few days ago. So the problem is new.
I tried on Windows with the same imaging data, and everything works fine.
I think what is happening on mac, is that the software is detecting the ranges in the black area outside the actual image - most probably only air as HU is -1024.

Thank you, Andras, I think I solved the problem by creating a new segmentation and then loading the master volume.
if any problem comes up in the future, I will let you know.

1 Like

That does not sound like a problem related to the operating system, but if you ever see issues that appear to be OS dependent let us know how to reproduce and we can test out on various machines.