Threshold range in 3D Slicer is [0, 99]

Hi guys,

I am trying to segment CT image. The data format is .nrrd and I can import it to Slicer successfully. I checked the import data and the voxel value is HU, which is from about -1000 to 1000.

However, when I use the Threshold feature in Segment Editor, the threshold range is limited to [0, 99], and I can not change it. I also tried to choose different Automatic Threshold (auto->maximum, minimum->auto, as lower, as upper), but it does not make any change.

I am a new user to Slicer. Am I missing something? Any suggestions are greatly appreciated. Thank you very much!

Best regards,
Mohan

Does it work correctly in latest Stable Release or in recent Preview Release? If not, could you please send the application log (menu: Help / Report a bug)?

Hello,
I have the same problem, that the Threshold range is limited to 99.00. I will Range from -1500 to 1500. What I can do?

Slider range should match range of intensity values in your volume. Please attach the application log to see any hint about what went wrong.

Problem report for Slicer 4.10.2 win-amd64: [please describe expected and actual behavior]

Hello,

my Problem is that the Threshold range go only from 0.00 to 99.00. But I will
-1500 to 1500 Range. Can you help me what the Problem is ?

Thanks

Hi,
I have two Slicer Version in my work PC. But both have problem. In Version 4.10.2 I can not croped the Volume. In Version 4.11. I can select the Threshold Range but the Apply function is not work and I dont get 3D Modell. My data have 10GB.

If your data set size is 10GB then you need about 100GB memory space to ensure you don’t run out of memory while performing various processing.

How much RAM do you have? How much virtual memory have you configured in system settings?

In Version 4.11.0 I have tha Trashold Range, but I can not appply and make 3D Modell.

. My PC have 64 RAM
Intel® Core™ i7-9700 CPU 3.00GHz 64Bit. Why the Slicer not work ?

Thanks

64 RAM Intel® Core™ i7-9700 CPU 3.00GHz 64Bit

What operating system do you use? How much virtual memory have you configured in system settings?

Windows 10 Enterprise and graphic card NVIDIA GeForce RTX 2070

Configure 100GB virtual memory in your system settings and let us know if it helped.

I’ve tested loading of a 10GB volume then segmenting in Segment editor using Threshold effect then create 3D model by enabling “Show 3D”. I’ve found a bug that caused Slicer to exit during model generation, but I’ve fixed it now, so Slicer Preview Release that you download tomorrow or later (revision 28581 or later) should work well.

Hello,
I have with the new Version the same problem today.

What mean this flag in Slicer? and the Data Volum is 22GB and by apply i get this error in picture.flagge


Can you please help me?

Task manager shows that you are running out of memory. The error message tells the same. Configure 50-100GB more virtual memory or crop and/or downsanple the image before starting segmentation.

The flag allows you to indicate for yourself that you a segment is correct and complete. It is essential when you have hundreds of segments. See details here: New feature: Search and filter in segments table

Hi,
3D Slicer is not work for DICOM Data.
I have the hard disk rate system expanded to 3TB. I can only open a finished 3D reconstruction, but I can not load a DICOM. What could be the problem?

PC:
intel Core i7-9700 CPU 3,00GHz
64GB
64Bit
Windows 10 Version 1803PC pc2
D-Laufwerk: 2,72TB
C-Laufwerk : 238GB

Can you please help?

Thanks

Did you try the things listed here:

https://www.slicer.org/wiki/Documentation/4.10/FAQ/DICOM

Hi All,
I seem to be running into the same issue with my threshold range. It is coming in at -2038.26 to 11956.00 which is way above HU units range of -1000 to 1000. Am I missing something or is this an error?

nick
image

The displayed threshold range is the volume’s intensity range. If it has these large numbers then it means that your volume has such large numbers in it. Even a single outlier single voxel value will alter the min/max value. You can get voxel position of these outliers using numpy:

a = array('MRHead')
import numpy as np
indices = np.where(a>200)
for i in range(len(indices[0])):
    print(f"voxel {i+1}: index = {indices[2][i]} {indices[1][i]} {indices[0][i]}, value = {a[indices[0][i],indices[1][i],indices[2][i]]}")
1 Like