Segments created in segment editor are a collection of unconnected stripes

I am new to 3Dslicer but I think it is a cool tool that could be useful for segmentation purposes. I hope you can help me.

When creating segments in the segment editor I encounter problems. I am running version 4.8.1 and I have the exact same problems in two different computers one of which is running Ubuntu and the other Windows:

I can draw the outline of the segment and right-click to create a connected segment but doing so most often does not result in the interior being colored but instead that the interior is divided into a pattern of colored and non-colored stripes. In the 3D view, the stripes also occur so it is not just a display problem. It is also not possible to interpolate between slices once this phenomenon occurs. Once the stripey look appears it also blends over to other slices that have not been contoured yet. I have has similar problems with “paint” but it is more repeatable with the “Draw” tool. Yesterday, the segment editor suddenly worked correctly but having restarted 3DSlicer today the problem is there again. Is the problem well known and do you have a work-around.

Thank you,

Hi Bo,

Probably your volume is non-axis aligned, and the slice you are drawing on is not one slice in the volume, but more. See discussion Display issue with RT structs and MR volume

Also I’d like to suggest using the nightly Slicer 4.9.0, there have been many fixes and minor improvements since 4.8.1.

Hi Csaba

Thank you for the response. I did actually also try the nightly build and the behavior was the same. I was using the sample “MR US prostate” data and that data was indeed rotated in the axial view. However after rotating it as you suggest, I cannot contour it. the moment I right-click or type “a” the contour disappears. Is that behavior expected?

Kind regards,

PS. I would not have bothered you had I only had problem with the ultrasound data.The stripey phenomenon was also a problem with sample data MRHead which should be axis-aligned. But right now this moment contouring works on MRHead, so I am somewhat confused about what caused the problem to go away for that sequence.

Axis directions of the binary labelmap representation inside a segmentation node is determined from the volume that you first select as master volume. Most likely you have (or segment editor module by default) selected a volume, which defined axis directions. If you later select a different master volume, then origin, spacing, and axis directions of the existing segmentation is not changed.

In the coming weeks, we plan to add setting dialog to the Segment editor that will allow changing axis directions, spacing, origin of the segmentation at any time, which should make things much more clear.

Until then, the easiest workaround is to create a new segmentation, make sure the volume that you select first as master volume is the volume that you’ll have as background volume during segmentation; and align the slice viewers to that volume’s axes.

Okay thank you, Andras.

Yes, the “feature” that Andras mentioned is not self-explanatory and is a serious factor for confusions in Segment Editor. I’m working on a solution right now, stay tuned!