There are no extensions in the extension manager-5.3.0 build

Hi, I built slicer from source, but I can’t find the extension in the extension manager, nor can I install it from the file. I click to open the webpage, and the expanded webpage doesn’t have any extensions either.
In the past two days, I tried to build the source code of the 5.2 and 5.3 versions, and also tried the release and debug modes. Only once in the 5.3 debug mode can I see the extension in the extension manager.
I confirm that it is not a network problem, what should I do so that my slicer can download and use the extension normally. I will be very grateful for your help!

This is what the interface looks like, and the extension has been unable to load. In the build directory, I found that the number of ini format files in the Slicer-build\NA-MIC directory is incorrect, and thejsonfile in theextensionfolder is empty. Really don’t know how to proceed. Hope to get your help.

Factory built extensions are only available for specific revision numbers corresponding to the commit used for the nightly build of extensions each night. However since you have built Slicer from source you cannot expect factory built extensions to appropriately work due to ABI compatibility issues. Therefore you should build the extensions you need from source as well. As a reminder you don’t generally need to build Slicer or extensions from source if they are Slicer scripted loadable modules which are written in python.

How to build extensions from source:

Thanks for your reply, after building the extension locally I was able to use it, thanks a lot!

1 Like