Build Slicer failed on win10


I followed the Build Instructions to build Slicer on Windows 10.
CMake: 3.19.3
Qt: 5.15.2 64-bit (MSVC 2019)
Visual Studio 2019 C++ x64
After build Slicer in Visual Studio, 5 errors occurred.

How to solve these errors? Thanks!

Not sure it is related to your error, but you need to use a short superbuild path on Windows. For example d:\s\S4D

1 Like

I try again.
The source folder is set to as C:\S4, and the build folder is set to as C:\S4R.

After build Slicer in Visual Studio, 5 errors also occurred.

I don’t know where the settings are wrong.
Please help me to solve these errors. Thanks!

The error list window in Visual Studio shows the errors in a somewhat random order. The errors that you show in the screenshot (all of them due to missing archive.h) are consequence of some previous errors that we don’t see.

Can you upload the full build log (not the content of “Error list” but content of “Output” window) somewhere and post the download link here?


Here is the full build log.

Thanks for your replay!

Probably the issue is that your system code page is set to 950 (Traditional Chinese) and c:\S4R\LibArchive\libarchive\archive_read_support_format_rar5.c contains characters that cannot be interpreted in this code page.

The simplest is to remove the offending characters (remove entire line 74, it is just a comment):

 * "Rar!→•☺·\x00"

If you will keep running into similar errors then you may consider switching to Latin1 code page for the build.

It’s solved by your method.
Thanks for your help!

Hello, I am a graduate student in a master class, and I am currently working on building a 3D slicer, and some building errors are happening to me. It is convenient for you to ask if the five errors are all solved by deleting the comments, or Is it useful for other solutions? If you are willing and available, is it convenient to email you for more details. Thank you! It doesn’t matter if you don’t want to, thank you for reading.

Machine-translated from Chinese

你好,我是一個碩班的研究生,目前也正在進行建置3D slicer的作業,有些建置錯誤我也正在發生,方便跟請問您五項錯誤都是把註釋刪掉就解決了嗎,還是有用了其他解決方式呢?如果您願意也有空,方便跟您要email請教詳細細節嗎。謝謝!不願意也沒有關係,謝謝您閱讀。